Ibm Aix Placement Papers - Ibm Aix Interview Questions and Answers updated on 26.Apr.2024

Either of the following two commands will display the network interfaces: lsdev -Cc if or ifconfig -a. To get information about one specific network interface, for eaxample tr0, run the command ifconfig tr0.

The no command sets or displays current or next boot values for network tuning parameters.

  1. Modify the /usr/lib/boot/unix directory and the /unix directory to be   a symbolic link to the binary for the desired kernel.
  2. Run the bosboot command to write a new system boot image.
  3. Reboot the system.

The path name of the 64-bit kernel is /usr/lib/boot/unix_64, and the path name of the multiprocessor versions of the 32-bit kernel is

/usr/lib/boot/unix_mp.

# ln -sf /usr/lib/boot/unix_mp /unix
# ln -sf /usr/lib/boot/unix_mp /usr/lib/boot/unix
# lslv -m hd5
# bosboot -ad /dev/ipldevice
# shutdown -Fr
# bootinfo -K (should now be 32)

  1. H/W error
  2. S/W error
  3. Operator error
  4. Unknown error.

JFS: JFS is normal filesystem. We cannot create large files in JFS.

Files can be access dynamically.
Max file system size=1TB
Max file size=64GB
Inode size=128b

JFS2: Can create a large size filesystems.

Files can be access accordingly as required. (not randomly or sequentially)
Max files system size=4PB
Max file size=4PB
Inode size=512

# startsrc –g [ Demon name ]
# stopsrc [Demon name ]
# refrest [Demon name ]
# lssrc –al

Check disk size belong to vg , take two same size disk to mirror

# bootinfo –s hdisk2
#lsvg –p rootvg

Add one more disk of same size of already have disk having rootvg.

# extendvg rootvg hdisk2
# lsvg –p rootvg

Now mirror vg with background sync LV. It sync LVs in background with new LVs

# mirrorvg –s rootvg

Create a boot image

# bosboot –ad /dev/hdisk2
#bosboot –ad /dev/hdisk1

Add a blv

record of newly added disk, first check and then add.

# bootlist –m normal -o
#bootlist –m normal hdisk2 hdisk1

To increase the size of the logical volume represented by the lv05 directory by three logical partitions, for example, type extendlv lv05 3.

# ls –li
# istat /etc/passwd

# errpt –a
# errpt –d H [H/W]
# errpt –d S [S/W]

  • mklvcopy LogicalVolumeName Numberofcopies
  • syncvg VolumeGroupName

To truly change the kernel to 64-bit from 32-bit, the system must be at the AIX® 5.1 or AIX 5.2levels.

# bootinfo –y

It shows a kernel is either 32-bit or 64-bit.

To truly change the kernel to 64-bit from 32-bit, the system must be at the AIX® 5.1 or AIX 5.2levels.

# bootinfo –y

It shows a kernel is either 32-bit or 64-bit.

To change to a 64-bit kernel, enter the following commands:

# ln -sf /usr/lib/boot/unix_64 /unix
# ln -sf /usr/lib/boot/unix_64 /usr/lib/boot/unix
# lslv -m hd5
# bosboot -ad /dev/ipldevice
# shutdown -Fr

#chvg –B vgname    /big vg
# chvg –S/-G vgname  /scale vg

You use the chvg command to change the characteristics of a volume group.

255 any no. of vg can create.

  1. permanent
  2. Temporary
  3. Informational
  4. Unknown.

#mkvg –y datavg –s 128 hdisk1 (pv name)
#mklv -y datalv –t jfs2 datavg 1
#crfs –v jfs2 –d datalv –g datavg –a size=10M –m /fs1

# cplv -v <new vg name> <sourcelvname>

Unmount all filesystems in VG.

# umount /test (mount point name)
#varyoffvg datavg
#exportvg datavg0

Importvg with new name

# importvg –y newvg hdisk4

#lsvg vgname
#lquerypv –M hdiskname

A major number refers to a type of device. A device number is a major number, and a minor number specifies a particular device of that type or sometimes the operation mode of that device type.

To activate the network interface tr0, run the command ifconfig tr0 up.

Normal vg -32 pv, 256 lv
# mkvg –y normvg –s 128 hdisk4
Big vg :- 128pv,512lv
# mkvg -B –y bigvg –s 128 hdisk9
Scalable vg: -1024pv, 4096 lv
# mkvg –S –y scalvg –s  512 hdisk1

VGDA: Volume Group Descriptor Area. It contains the information about volume group to which the physical volume belongs to. It also contains the information about physical partitions, logical partitions and logical volumes.

VGSA: Volume Group Status Area it contains the information about physical partition from all physical volumes of the same volume group. It contains the status of VG

PP size can be changed using a T-factor. If not then add a partitions in VG by adding one disk.

# chvg –t3 rootvg

You can run the alt_disk_copy command to copy the current rootvg to an alternate disk. The following example shows how to clone the rootvg to hdisk1: alt_disk_copy -d hdisk1.]

You can display all logical volumes that are part of rootvg by typing the following command: #lsvg -l rootvg/

Type one of the following: ifconfig -a or host Fully_Qualified_Host_Name. For example, host cyclop.austin.ibm.com.

# chvg –vy pv_name
# chvg –vn pv_name
#chvg –Qn vgname
#chvg –Qs vgname

#rmdev -l hdiskx
#chdev -l hdiskx -a max_trfer=0*80000
#mkdev -l hdiskx

extendvg VolumeGroupName hdisk_new
migratepv hdisk_bad hdisk_new
reducevg -d VolumeGroupName hdisk_bad

#mklv -y name_of_logical_volume name_of_volume_group number_of_partition

To display routing table information for an Internet interface, type netstat -r -f inet. To display interface information for an Internet interface, type netstat -i -f inet. To display statistics for each protocol, type netstat -s -f inet.

Run the following command to display information about the logical volume #lv1: lslv lv1.

First check the blv record using,

# bootlist –m normal –o

Remove the old blv record, using

# chpv –c hdisk2
# bootlist –m normal hdisk1
# bootlist –m normal hdisk2

Now unmirrorvg

# unmirrorvg rootvg hdisk2
# reducevg rootvg hdisk2
#lsvg –p rootvg
# lspv
# bootlist –m normal –o

Use the following command, where s partition_size sets the number of megabytes (MB) in each physical partition where the partition_size is expressed in units of MB from one through 1,02@(It’s one through 131,072 for AIX 5.3.)

mkvg -y name_of_volume_group -s partition_size list_of_hard_disks

The partition_size variable must be equal to a power of two (for example: one, two, four or eight). The default value for standard and big volume groups is the lowest value to remain within the limitation of 1,016 physical partitions per physical volume. The default value for scalable volume groups is the lowest value to accommodate 2,040 physical partitions per physical volume.

Available state and defined state. When device is in defined state it me it cannot use. Not in ready state. Run cfgmgr try to make available known in the system that device. Available state me that device is ready to use

# lsdev –Cc disk

It displays which disks are available

Run the lsvg command on the volume group and look at the value for MAX PVs. The value is 32 for normal, 128 for big and 1,024 for scalable volume group.